Uofficiel SOHO77 FAQ/OSS

Denne FAQ er uofficiel. Den er tilegnet de brugere af WOL ADSL der har en Cisco SOHO 77 router.

Husk hvis du har en Cisco 677 router, kan denne FAQ ikke bruges! Se istedet http://www.paikin.dk/adsl-faq.phtml - Her finder du også generelle World Online ADSL spørgsmål.

Denne FAQ blev sidst rørt 22/09-2004 23:11

Oversigt:

Hvorfor kan jeg ikke telnette til min server?
Hvordan "går jeg i config"?
Hvordan tilføjer jeg NAT entries?
Hvordan sletter jeg NAT entries?
Hvordan ser jeg mine NAT entries?
Hvordan begrænser jeg DHCP adresserummet?
Hvordan ændrer jeg password i min router?
Hvordan slår jeg DHCP på routeren fra?
Hvorfor virker min NetMeeting ikke?
Hvordan ser jeg hastigheden på min linie?
Hvordan ser jeg mit eksterne IP nummer?
Hvordan slår jeg NAT fra og kører flere IP numre?
Hvordan sætter jeg mIRC op til at bruge DCC
Hvordan sætter jeg timeout?
Mere NetMeeting
Hvordan kan jeg bruge VPN/PPTP
Hvordan stiller jeg uret i routeren?
Hvordan kommer jeg enable mode?
Min servers domæne resolver til 192.168.1.2 - Hvordan ændrer jeg det?
Hvordan kører jeg en HotLine server?
Hvordan fjerner jeg et NAT entry der er i brug?
Hvordan ser jeg min nuværende konfiguration?
Hvordan ændre jeg IP adresse og subnet-maske?
Hvordan ændrer jeg den adresse, som udefrakommende trafik bliver sendt til?
Where do I find the SOHO 77 configuration notes?
Hvordan laver jeg en Half Life server?
Hvordan telnet'er jeg til min router?
Montering af Wireless Accesspoint


Indhold:

Hvorfor kan jeg ikke telnette til min server?

Som default er SOHO'en sat op til at modtage alle requests på port 23 - Det er dennes prompt du ser når du prøver!
Forbind til din router, enable og gå i config. Skriv nu:

no ip nat inside source static tcp 192.168.1.1 23 interface dialer0 23

Det kan dog være rart at kunne komme ind på routeren udefra. Den gamle 677'er havde port 23000 NAT'et til dette formål, lad os lave det samme nummer! I config skriv:

ip nat ins sou sta tcp 192.168.1.1 23 int dialer0 23000

Nu kan du nå routeren ved at telnette til port 23000.

Sidst ændret 27/06-2001 15:39.


Hvordan "går jeg i config"?

Forbind til din router, gå i enable og skriv:

configure terminal

Dette kan forkortes (som de fleste IOS kommandoer kan) til:

conf t

Du kommer ud af config ved at trykke <CTRL>+Z (^Z).
Du kan gemme din config når du er ude af config ved at skrive write

Sidst ændret 06/05-2001 03:26.


Hvordan tilføjer jeg NAT entries?

Du connecter til din router, enabler og går i config. Formatet er:

ip nat inside source static <protokol> <intern ip> <port> interface dialer0 <port>

Protokol er enten tcp eller udp. F.eks. NAT'es port 4000 til 192.168.1.10 således:

ip nat inside source static tcp 192.168.1.10 4000 interface dialer0 4000

Sidst ændret 06/05-2001 03:26.


Hvordan sletter jeg NAT entries?

Du connecter til din router, enabler og går i config. Formatet er:

no ip nat inside source static <protokol> <intern ip> <port> interface dialer0 <port>

F.eks. slettes NAT'en der peger port 4000 over til 192.168.1.10 således:

no ip nat inside source static tcp 192.168.1.10 4000 interface dialer0 4000

Sidst ændret 06/05-2001 03:26.


Hvordan ser jeg mine NAT entries?

Connect til din router, skriv:

sh ip nat trans

Sidst ændret 06/05-2001 03:26.


Hvordan begrænser jeg DHCP adresserummet?

Der er to måder at gøre det på. Den første og mest besværlige kommer her:
Forbind til din router, enable og gå i config og skriv:

ip dhcp pool <dit pool navn>
  network <network> <subnet>
  default-router <din routers ip>
  dns-server 212.54.64.170 212.54.64.171
  lease 0 1


Din routers IP er som default 192.168.1.1. Default pool navn er soho77.
Antag at du kun vil bruge adresserne 192.168.1.32-192.168.1.63 (det er ikke inklusive).
Så skal du ændre <network> til 192.168.1.32 og <subnet> til 255.255.255.224.

Du kan regne subnet masker til IP adresser ud her.

Den anden og lettere måde går ud på at du har dit eksisterende dhcp adresserum, og blot udelader nogle adresser fra dette adresserum (din DHCP pool).
Antag at du vil udelade adresserne 192.168.1.40 til 192.168.1.72.
I config skriv:

ip dhcp exclude 192.168.1.40 192.168.1.72

Sidst ændret 12/05-2001 15:41.


Hvordan ændrer jeg password i min router?

Forbind dig til din router, enable og gå i config.

Skriv:

line vty 0 4
  password <PASS>
line con 0
  password <PASS>


For at ændre Enable password:

enable secret <PASS>

Sidst ændret 05/07-2001 19:16, indsendt af Peter Reinhold.


Hvordan slår jeg DHCP på routeren fra?

Forbind til ruteren, enable og gå i config og skriv:

no service dhcp

Sidst ændret 09/05-2001 21:12.


Hvorfor virker min NetMeeting ikke?

I NetMeeting, under "Advanced Calling Options" vælges "Use Gateway.." - Gateway sættes til routerens adresse 192.168.1.1 SOHO 77. På den måde kan alle PC'er på lokalnettet anvende Netmeeting.
Det skal siges at du kan "ringe ud" - men ikke modtage opkald. Det kan du kun hvis din PC har IP nummer 192.168.1.2

Se også "Mere NetMeeting"

Sidst ændret 20/06-2001 02:18, indsendt af Nickie Sølling Hansen.


Hvordan ser jeg hastigheden på min linie?

Forbind til din router og skriv:

sh dsl int atm0

Sidst ændret 09/05-2001 21:33.


Hvordan ser jeg mit eksterne IP nummer?

Forbind til din router og skriv:

sh ip in br dial0

Sidst ændret 10/05-2001 02:21.


Hvordan slår jeg NAT fra og kører flere IP numre?

Hvis du har fået tildelt et ip range - fx. 212.52.72.184 - 191 så sætter
du routeren op ved at gå i config og skrive:

int eth0
  ip address 212.52.72.185 255.255.255.248


(ip nummeret udskiftes med det som man ønsker routeren skal have)

end
write
reload


Login igen og slet det filter det bestemmer adgangen inside out
(bestemmer hvilke IP'er der skal igennem routeren), i config skriv:

no access-list 1
access-list 1 permit 212.52.72.184 0.0.0.255


Bemærk, at masken 0.0.0.255 er omvendt og svarer til 255.255.255.0

disable nat fuldstændig på den indvendige side

no ip nat inside
end
write
reload


På denne måde udnytter du godt nok ikke det faste ip nummer som du har fået tildelt af WOL, men til gengæld tilfredsstiller du kravet fra visse firewalls (fx. 3Com OfficeConnect) om at routerens ip nummer skal være i samme net som firewallens wan-side ip nummer. Trafik til DMZ og firewallen går uhindret igennem og al processing sker i firewallen.

Sidst ændret 12/05-2001 16:33, indsendt af Henrik Sørensen.


Hvordan sætter jeg mIRC op til at bruge DCC

Under Connect->Local info:
IP Address: <din eksterne ip>
I feltet "On connect, always get:" skal "Local Host" og "IP Address" ikke være krydset af.
Lookup method skal være sat til server.

Sidst ændret 13/05-2001 02:14, indsendt af Caspar Due.


Hvordan sætter jeg timeout?

I config skriv:

int dialer0
time abs <minutter>

Sidst ændret 14/05-2001 00:19.


Mere NetMeeting

Følgende porte skal åbnet på soho 77, så kan du modtage ind/ udgående kald via netmeeting.

ip nat ins sou sta tcp w.x.y.z 389 int dialer0 389
ip nat ins sou sta tcp w.x.y.z 522 int dialer0 522
ip nat ins sou sta tcp w.x.y.z 1503 int dialer0 1503
ip nat ins sou sta tcp w.x.y.z 1720 int dialer0 1720
ip nat ins sou sta tcp w.x.y.z 1731 int dialer0 1731


w.z.y.z er din interne IP - f.eks. 192.168.1.10
Denne gør at du kan modtage og sende opkald fra een maskine.

Sidst ændret 25/10-2001 00:39, indsendt af Darki.


Hvordan kan jeg bruge VPN/PPTP

(Gælder for VPN for Microsoft servere)

ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp xxx.xxx.xxx.xxx 1723 interface Dialer0 1723

access-list 100 permit ip any any
...
access-list 100 permit gre any host xxx.xxx.xxx.xxx


Fra Ole Kristensen, på worldonline.dk.adsl.teknik

Sidst ændret 16/06-2001 02:16.


Hvordan stiller jeg uret i routeren?

Gå i enable-mode og skriv:

clock set 10:17:00 14 june 2001

Formatet er "hh:mm:ss day month year" hvor "month" er månedsnavnet skrevet på engelsk. clock set ? viser ikke det korrekte format.

Sidst ændret 15/06-2001 03:48, indsendt af Martin Liversage.


Hvordan kommer jeg enable mode?

Skriv enable
Adgangskoden står i de papirer du fik sammen med routeren fra Tiscali (World Online).

Sidst ændret 12/07-2001 00:52, indsendt af Søren Kristensen.


Min servers domæne resolver til 192.168.1.2 - Hvordan ændrer jeg det?

I reglen fungerer det fint med denne opsætning, men du kan godt omgå denne opførsel hvis det generer dig. Gå i config og skriv:

no ip nat ins sou static 192.168.1.2 w.x.y.z extendable

Hvor w.x.y.z er din eksterne IP.
Nu skulle den resolve til dit externe IP.

Sidst ændret 28/07-2001 14:32.


Hvordan kører jeg en HotLine server?

Gå i config og skriv:

ip nat ins sou sta tcp w.x.y.z 5500 int dialer0 5500
ip nat ins sou sta tcp w.x.y.z 5501 int dialer0 5501
ip nat ins sou sta tcp w.x.y.z 5502 int dialer0 5502
ip nat ins sou sta tcp w.x.y.z 5503 int dialer0 5503


Hvor w.x.y.z er din interne IP.

Sidst ændret 21/06-2001 19:36.


Hvordan fjerner jeg et NAT entry der er i brug?

Gå i enable, og åbn f.eks. notpad og skriv følgende kode:

 clear ip nat translation *
 configure terminal
 no ip nat <etc>


<etc> er resten af din kode, så den f.eks. ser sådan ud: no ip nat ins sou sta tcp w.x.y.z 5500 int dialer0 5500

Sidst ændret 28/07-2001 19:40.


Hvordan ser jeg min nuværende konfiguration?

I enable skriv: sh run

Sidst ændret 31/07-2001 15:04.


Hvordan ændre jeg IP adresse og subnet-maske?

I config skriv:

in e0
ip addr x.x.x.x y.y.y.y


Hvor x.x.x.x er den nye IP adresse, og y.y.y.y er den nye subnet-maske.

Nu fryser skærmen, da IP/subnet skiftes med det samme. Du kan nu bruge din nye IP/subnet.

Sidst ændret 1/10-2004 22:39, indsendt af Nicolai Lund rettelse af Henrik Jensen.


Hvordan ændrer jeg den adresse, som udefrakommende trafik bliver sendt til?

Som standard bliver alt trafik, som kommer udefra, sendt til ipadressen 192.168.1.2. Men hvis du har lavet det interne net om til f.eks. 192.168.0.0, og din firewall f.eks. har ip'en 192.168.0.2 - Så skal trafikken sendes til denne istedet.

Det sker med følgende kommandoer:

enable
clear ip nat translation *
configure terminal
no ip nat inside source static 192.168.1.2 <ekstern ip>
ip nat inside source static 192.168.0.2 <ekstern ip>
write
reload


Hvordan du finder den eksterne ip, kan du finde her...

Sidst ændret 13/08-2001 00:43, indsendt af Danni Finne.


Where do I find the SOHO 77 configuration notes?

Tommi sent us these two links: The "Official" Configuration Notes from Cisco for SOHO 77 router, and the same one in PDF format

Sidst ændret 18/11-2001 17:24, indsendt af Tommi.


Hvordan laver jeg en Half Life server?

Gå i config og skriv:

ip nat ins sou sta tcp w.x.y.z 7002 int dialer0 7002
ip nat ins sou sta udp w.x.y.z 27005 int dialer0 27005
ip nat ins sou sta udp w.x.y.z 27009 int dialer0 27009
ip nat ins sou sta udp w.x.y.z 27010 int dialer0 27010
ip nat ins sou sta udp w.x.y.z 27011 int dialer0 27011
ip nat ins sou sta udp w.x.y.z 27012 int dialer0 27012
ip nat ins sou sta udp w.x.y.z 27015 int dialer0 27015


Hvor w.x.y.z er din interne IP.

Sidst ændret 23/11-2001 15:28.


Hvordan telnet'er jeg til min router?

Vælg Start | Kør og skriv:

telnet 192.168.1.1

Sidst ændret 23/11-2001 15:30.


Montering af Wireless Accesspoint

Løsninger er ganske simpel. Access pointet fungerer som en bridge, hvorfor det blot skal monteres direkte til routeren. Have en netværksadresse der passer til routerens. 192.168.1.xxx, Jeg valgte 192.168.1.254. Routeren har 192.168.1.1, Hvorfor denne sættes som Default Gateway på AP. De(n) lokale
maskiner kan herefter anvende ip adresser inden for ovenstående rum. Med standard opsætningen fra WOL skal en evt. intern server stadig have adressen 192.168.1.2.

Sidst ændret 06/06-2002 11:49, indsendt af Michael Høtoft.




Hvis du sender mig mails med spørgsmål, skal du ikke nødvendigvis forvente svar... Prøv istedet worldonline.dk.adsl.teknik, der er større chance for at du får et brugbart svar dér, også du kan du jo indsende en FAQ her (soho77[at]kauf.dk) bagefter :)

[33116]

Valid XHTML 1.0! Valid CSS!